Back to overview
Downtime
Temporary Connectivity Disruption
Apr 30, 2026 at 12:01am UTC
Affected services
NEXIS4
Resolved
Apr 30, 2026 at 8:15am UTC
A connectivity issue in our edge layer caused a subset of HTTPS requests to fail. The underlying configuration was corrected and propagation completed at 10:15 CET. No backend systems or customer data were impacted.
Affected services
Created
Apr 30, 2026 at 12:01am UTC
We are currently experiencing connectivity issues affecting our services. Our team is actively investigating the root cause and working to restore full functionality as quickly as possible.
Affected services